PHP, which is a recursive initialism for PHP: Hypertext Preprocessor, is among the most commonly used multi-paradigm programming languages available out there. Any website or app built with PHP will run on a given web server provided that a PHP module is enabled, which makes the language absolutely universal and it is little surprising that there are actually a few million web servers that support it and hundreds of millions of PHP-driven websites hosted on them. PHP is preferred over HTML due to the fact that it allows you to build a dynamic site with a lot of features. A PHP-based community portal, for instance, will display unique web content to each visitor although the URL will remain the same. In comparison, HTML-based websites are static and the page content can be modified only manually. Like any other software program, PHP has several versions and the one that was used while setting up a specific website must be available on the server so that the site can run faultlessly.
PHP 4 and PHP 5 Support in Shared Hosting
Our shared hosting servers support different PHP versions, which means that your sites will work correctly even if your scripts are outdated. We recognize the fact that an old site does not always mean a vulnerable one as you may have carried out plenty of code modifications. That’s the reason why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can pick which one will be active for your hosting account. You can change the version with only one single click through your Hepsia hosting Control Panel and the new settings will be applied straight away. In case you would like to run both newer and older scripts, there is even an option to use a different PHP version for each of your domain names simultaneously.
PHP 4 and PHP 5 Support in Semi-dedicated Hosting
Our Linux semi-dedicated hosting packages support multiple PHP versions, which means that you’ll be able to use all the web applications that you have developed over the years. The Hepsia Control Panel, which comes bundled with each account, will allow you to set the required version with only one mouse click. You can select between PHP 4, 5.2, 5.3, 5.4 and 5.5. If you wish to host multiple websites under one single account and they have diverse requirements related to the web hosting environment, you will be able to specify a different version for each and every one of them irrespective of which version has been selected for the account itself. That’s possible owing to our custom-developed cloud hosting platform, which permits us to run different versions of PHP all at once. In contrast, the great majority of web hosts typically offer one, in very rare cases – two versions.